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Troubleshooting Document Folder Access, Visibility, and Deletion Issues

This article will help you to solve various Document Management related issues.

When a user cannot view, edit or delete documents or folders, this is usually due to missing permissions, missing folder access, document lifecycle status or an active Model link.

Symptoms

  • User cannot view a folder or document

  • User can open a document but cannot edit it

  • User cannot delete a folder or document

  • Delete button is unavailable or returns an error

Possible causes
  • Missing permissions for the Document Control module
  • Folder restricted to specific user groups
  • User not assigned to the correct user group
  • The document has an active Lifecycle procedure and is not published yet
  • Document linked to an active Model

Solution A: Check Document Control module permissions

Use this solution if the user cannot edit or delete any documents or folders.

  1. In the menu bar go to Management > Permissions > Module
  2. Select the impacted User Group(s) and click Show
  3. Locate the Document permissions section
  4. Verify the User Group has permission to ''Manage documents and folders''
  5. Ensure the permission box is selected, click Save
  6. Ask the user to log out, log back in and test

Expected result: User can edit and delete the required folder(s) or documents.

Solution B: Check Document folder permissions

Use this solution if the user cannot view the expected folder and its documents.

  1. In the menu bar go to Management > Permissions > Document folders
  2. Select the impacted User Group(s) and click Show
  3. Locate the relevant folder
  4. Verify if User Group has permission
  5. If the User Group does not have permission to this folder, then select it and click Save
  6. Ask the user to log out, log back in and test

Expected result: User can view the folder and its documents.

Solution C: Check User Group assignment

Use this solution if the correct permissions are already configured, but the user still does not have access.

  1. In the menu bar go to Management > Users > Users
  2. Verify that the impacted user is assigned to the correct Group
  3. If the user is not assigned to the correct Group, then click on the Edit icon, change the User group and click Save
  4. Ask the user to log out, log back in and test

Expected result: User receives the correct access to folders and documents.

Solution D: Check Document Lifecycle status

Use this solution if multiple users cannot access the document. Below steps should be performed by system admins or the documents’ Owner or Delegate.

  1. In the menu bar go to Documents > Document overview
  2. Navigate to the relevant document
  3. Verify if in front of the documents’ name there is a label called Unpublished
  4. If the document has this label then the document needs to go through the different Lifecycle phases before being published
  5. Click on the Lifecycle procedures icon to view the steps that need to be taken in order for this document to be published
  6. Either leave a comment on this page or send a reminder to the involved users to get this document published
  7. After publication, ask the impacted user(s) to test

Expected result: User can view the document.

Solution E: Check for active documents in folder

Use this solution if the user cannot delete a folder.

    • In the menu bar go to Documents > Document overview
    • Navigate to relevant folder and open it
    • Verify whether there is a document within the folder
    • If there is, then either delete the document or adjust its’ folder
    • Try deleting the folder again

Expected result: Folder can be deleted successfully.

Solution F: Check for active links to Models

Use this solution if the user cannot delete a document.

  1. In the menu bar go to Documents > Document overview
  2. Navigate to the relevant folder
  3. Navigate to the relevant document
  4. Click on the Active assignments icon
  5. Verify whether the document has any Assignments to models
  6. If so, in the menu bar go to Documents > Models
  7. Locate the relevant Model
  8. Click on the Edit icon
  9. Click open the Attachment frames to check where the document is assigned
  10. Delete all assignments by clicking on the Delete icon
  11. Click on Save
  12. Run through steps 6 through 11 to delete all active assignments
  13. Try deleting the document again

Expected result: Document can be deleted successfully.

If the issue persists

Contact the Support Team and provide:

    • The URL or Name of the impacted folders and/or documents
    • Any errors received
    • A list of impacted user(s) or user group(s)
    • Any troubleshooting steps you have already tried